Account locking on backup access
Incident Report for Reincubate
Resolved
The updates that we pushed out last year resolved the locking issues. We remain interested in hearing reports from any end-users that still encounter these.
Posted May 14, 2020 - 15:37 BST
Monitoring
We've completed the rollout for all clients' new end-users, and are liaising directly with clients on migration of existing end-users as we continue to monitor performance.
Posted Aug 01, 2018 - 18:32 BST
Update
We started rollout of a solution Fri 27th, and by yesterday had it scaled up to cover new end-users on most client accounts. We expect to fully deploy it for all API users tomorrow.
Posted Jul 31, 2018 - 19:04 BST
Identified
Our testing has progressed well and have pushed a number of updates live. We are continuing to work on the issue.
Posted Jul 25, 2018 - 18:14 BST
Investigating
We are investigating a series of locks on iCloud accounts subsequent to access of their backup data. The locks occurred morning of 21st July.

Services for real-time iCloud data and iTunes backup data via the API are unaffected.
Posted Jul 23, 2018 - 11:43 BST
This incident affected: ricloud API / iCloud service.