Elevated API Errors
Incident Report for Reincubate
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 21, 2024 - 21:00 BST
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Oct 21, 2024 - 17:09 BST
This incident affects: ricloud API / iCloud service.