CallKit sync bug in Apple's iOS 13 builds
Incident Report for Reincubate
Resolved
This incident is being closed as Apple's latest changes to iCloud access no longer make it feasible to access CallKit data. The status of this CallKit sync issue is therefore unresolvable.
Posted Apr 01, 2021 - 16:01 BST
Monitoring
Apple appear to have resolved this issue in the latest iOS 13.5 betas. We're expecting that they will resolve the problem in the coming weeks, and we will update this accordingly.
Posted May 14, 2020 - 15:38 BST
Update
This issues is still present in the latest release of iOS 13.3.1. We will keep this incident updated with future changes.
Posted Feb 11, 2020 - 11:24 GMT
Update
From our ongoing tests, this issue is still present in the latest iOS release (13.2.3). An upcoming iOS release is expected to resolve the error causing CallKit call history sync to fail on affected accounts. We will keep this incident updated with future changes.
Posted Nov 22, 2019 - 15:19 GMT
Identified
We’ve seen a number of call sync failures stemming from iOS 13.1.2 and 13.2 devices, caused by an issue in iOS 13 affecting the devices’ ability to synchronise call data. As this is dependant on Apple’s own synchronisation mechanism, we have escalated this to them and a forthcoming iOS update will be required to resolve it.
Posted Nov 05, 2019 - 14:35 GMT
This incident affected: ricloud API and ricloud API / iCloud service.